Announcement

Collapse
No announcement yet.

Can't select animation.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't select animation.

    I have followed this tutorial:
    https://github.com/WaveEngine/Docume...animated-model

    This tutorial shows how to load an animated model. Importing the model is no problem at all, nor adding animations. Selecting the right animation in the Animation 3D component is where things arent working the way wish they were. The 'CurrentAnimation' combo wont enable me to select an animation, since there are no options to select.




    I am using Ubuntu 14.04

    Is it a bug or did I do something wrong?
    Last edited by kapstok; 09-23-2015, 11:42 AM.

  • #2
    I have tried adding the animation through code (monodevelop). It seems that my WaveEngine.Components is missing an .Animation directive. I updated the .Component package but this did not solve the problem.

    CODE:

    protectedoverridevoidCreateScene()
    {
    this.Load(WaveContent.Scenes.MyScene);

    Entitymodel=newEntity()
    .AddComponent(newTransform3D())
    .AddComponent(newMaterialsMap())
    .AddComponent(newSkinnedModel(WaveContent.Assets.Characters.Isis.isis_fbx))
    .AddComponent(newAnimation3D()) // Debugger error here!

    .AddComponent(newSkinnedModelRenderer());

    EntityManager.Add(model);
    }


    DEBUGGER ERROR:

    Error CS0246: The type or namespace name `Animation3D' could not be found. Are you missing `WaveEngine.Components.Animation' using directive?

    Comment


    • #3
      Hi Kapstok,

      I checked WaveEngine.Component library and it include Animation3D type. You can check it on:
      Components nuget package->Mono->WaveEngine.Components.dll

      On the other hand, Did you tried to open weproj file from Animation Model Sample?

      Finally, Can you send me your project?

      I'm look forward to hearing from you

      Thanks for your feedback
      Regards!
      Jorge Cantón

      Comment


      • #4
        Hello Jorge Cantón,

        I have tried to add WaveEngine.Components.dll . The computer did update some packages, but it didn't solve the problem.

        I haven't tried to open the weproj file yet. I'll give it a shot. Should I add it to MonoDevelop the same way as adding the WaveEngine.Components.dll file?

        Downloading my project as attachment didn't work, so here is the download link:
        https://mega.nz/#!84UxXSyZ!LsTEXALZW...UmLUW_qvWyBsBU

        Regards,
        ​Jan Allersma
        Last edited by kapstok; 09-24-2015, 08:50 PM.

        Comment


        • #5
          Hi Kapstok,

          The compilation problems is because you need resolve some dependencies. If you use Animation3D component you need to add the following line to your using block:

          using WaveEngine.Components.Animation;

          Complete code
          Code:
          #region Using Statements
          using WaveEngine.Components.Animation;
          using WaveEngine.Components.Graphics3D;
          using WaveEngine.Framework;
          using WaveEngine.Framework.Graphics;
          #endregion
          
          namespace TreasureGreed
          {
              public class MyScene : Scene
              {
                  protected override void CreateScene()
                  {
                      this.Load(WaveContent.Scenes.MyScene);
          
                      Entity model = new Entity ()
                          .AddComponent (new Transform3D ())
                          .AddComponent (new MaterialsMap ())
                          .AddComponent (new SkinnedModel (WaveContent.Assets.Characters.Isis.isis_fbx))
                          .AddComponent (new Animation3D ())
                          .AddComponent (new SkinnedModelRenderer ());
          
                      EntityManager.Add (model);
                  }
              }
          }


          On the other hand, I created an Animation3D project sample for you with your assets (download here). Anyway we are working an issue on Linux platform because if you change animation list of a isis model you need to reload Wave Visual Editor for detect the changes so I think that it will be fixed on next release soon.

          We are glad to see linux developers using Wave Visual Editor . At the begining we were not sure to work in Linux support because other engine haven't support.

          Thanks for your support!

          Regards!
          Jorge Cantón

          Comment

          Working...
          X