Announcement

Collapse
No announcement yet.

Not able to launch WaveEditor

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by Jorgemagic View Post
    Hi Bartek22,

    We need more details. Which is your SO system and graphics card?

    Thanks for your feedback!
    Best
    Jorge
    I am attaching more details regarding the Windows 10 x64 machine for which I experience this issue. The error appears with freezing splash screen.

    I have also found in the logs:

    w SharpDX.Result.CheckError()
    w SharpDX.Direct3D11.Device.CreateTexture2D(Texture2 DDescription& descRef, DataBox[] initialDataRef, Texture2D texture2DOut)
    w WaveEngine.DirectX.RenderTargetManager.CreateDepth Texture(Int32 width, Int32 height, Int32 sampleCount)
    w WaveEngine.Adapter.BaseApplication.CreateDepthBuff er()
    w WaveEngine.Adapter.BaseApplication.ResizeBuffers()
    w WaveEngine.Adapter.BaseApplication.BaseRender()
    w WaveEditor.WaveIntegration.DirectXWidget.<OnTimer> b__25_0()
    28 Jun 2016 22:11:42,985 ERROR - Exception
    SharpDX.SharpDXException: HRESULT: [0x80070057], Module: [General], ApiCode: [E_INVALIDARG/Invalid Arguments], Message: Parameter is incorrect.

    As it can be seen in the screenshot of the splash screen attached - the texture does not cover a whole available space. Does it mean that the texture in this particular case is too large for my graphical devices ?

    I had the Visual Editor working without this error at one point on this machine using Linux Ubuntu OS (in dual boot with Windows 10).

    Kind regards,
    Bartek

    Comment


    • #32
      Hi Bartek22,

      As logs says, there is an error invoking Direct3D11 and your graphics seems to support DX10.1 (lower version), so maybe there is some kind of compatibility issue between some features used by the engine on Windows. You can try to check if there are any driver updates, but I am not sure this could solve your problem, regarding to your card characteristics.

      In Linux, engine works with OpenGL, and that's why it runs in your Ubuntu environment.

      Regards
      Last edited by sescalada; 06-30-2016, 02:27 PM.

      Comment


      • #33
        Originally posted by amerkoleci View Post
        I solved it, you need to uninstall GTK# first and also all version of GTK#, if you have version 3.0 too, then install it from zero, that worked for me.
        NOOOOOOOOOOOO DO NOT INSTALL NEWEST VERSION OF GTK SHARP 3 because Gtk Sharp 3 is incompatible to OpenGL >3.3

        Gtk Sharp 3 looks liable package.

        Please make sure to download original Gtk Sharp 2 from Mono website!

        And I have found wrong "Release" while your wave editor generates WinForm, WPF, Gtk#2 and If I want build and run and compiler throws error because "Release" is wrong just replace to "Released" than it works fine.

        Nice idea of Wave Team ^^!

        I wish I have to help you if you want and protect to mkbundle whole waveeditor and any executables into standalone executables Because We feel WaveEngine "unsafe". Thanks!

        Comment

        Working...
        X