No announcement yet.

Where is the "HoloLensProvider" and how do I build a test project for the HoloLens?

  • Filter
  • Time
  • Show
Clear All
new posts

  • AntonioAvila
    Hi Nyanpasu.

    The HololensProvider class has now changed to MixedRealityProvider. That new class works both in HoloLens and the new Microsoft's VR headsets

    Thank you for using Wave Engine!


    Leave a comment:

  • Nyanpasu
    I think I managed to get past the previous steps (but not really sure since I have hacked so much now by going back and forth), but whenever I add a new C#-file to the Source (for example Test.cs) and do what I am supposed to do, it won't appear in the Behaviour-components list even after the WaveEditor acknowledges that I have done something.

    What is going on?

    Edit: I have tried a lot of different things now but same result. Still nothing appears of selectable components in WaveEditor...
    Last edited by Nyanpasu; 08-01-2018, 02:41 PM. Reason: Tested further

    Leave a comment:

  • Nyanpasu
    This article is new but still it links to a 404:

    This link which is the same as in the previous articles, also linked to in this article, is not working:

    I do not know how to proceed now without doing a lot to make it work.

    I found it in another branch:

    Maybe update the URLs?
    Last edited by Nyanpasu; 08-01-2018, 11:13 AM. Reason: Uncovered branche

    Leave a comment:

  • Nyanpasu
    Trying to open the MixedRealitySample-project located here crashes WaveEditor:

    I tried a few of the other projects and they all opened without an issue. I have no idea why only the MixedReality-one should create an issue. I have worked on the HoloLens using Unity 3D since January and completed several projects for it. I do not know what I am missing here.

    I managed to get a fail-message in the WaveEditor now:

    "FAIL to compile project: C:\wevs\Samples-master\Extensions\MixedRealitySample\Launchers\Win dows\MixedRealitySample.csproj"

    Here is the message in the console:

    "01 Aug 2018 13:02:50,613 WARN - SceneVM | Could not load scene C:\wevs\Samples-master\Extensions\MixedRealitySample\Content\Scene s\MyScene.wscene
    System.Exception: The file C:\wevs\Samples-master\Extensions\MixedRealitySample\Content\Scene s\MyScene.wscene cannot be deserialized. ---> System.Runtime.Serialization.SerializationExceptio n: Feil på linje 1, posisjon 618. Elementet WaveEngine.Framework:Component inneholder data fra en type som er tilordnet navnet Deserialiseringsprogrammet har ikke opplysninger om noen type som er tilordnet dette navnet. Vurder å bruke DataContractResolver hvis du bruker DataContractSerializer , eller legg til typen som tilsvarer ControllerBehavior i listen over kjente typer. Bruk for eksempel attributtet KnownTypeAttribute, eller legg det til i listen over kjente typer som er sendt til serialiseringsprogrammet."

    I tried some stuff now but it seems I need version of the WaveEngine.HoloLens, but I can only get from here:

    In the NuGet-manager in the sample project it says that it is "Not available in this source".

    I tried reinstalling everything and now I get this error:

    "C:\wevs\Samples-Release-2.3.1\Extensions\HololensSample\SharedSource\Main\ VoiceCommands.cs(73,55): error CS1061: 'Entity' does not contain a definition for 'FindAllChildrenByTag' and no extension method 'FindAllChildrenByTag' accepting a first argument of type 'Entity' could be found (are you missing a using directive or an assembly reference?)"

    Here is the line in code:

    "foreach (Entity soundEntity in this.Owner.FindAllChildrenByTag(EngineTag))"
    Last edited by Nyanpasu; 08-01-2018, 12:02 PM.

    Leave a comment:

  • Nyanpasu
    As a follow-up I updug and loaded down this:

    It still didn't add the "HoloLensProvider". What am I doing wrong?

    Leave a comment:

  • Where is the "HoloLensProvider" and how do I build a test project for the HoloLens?

    This link is dead:

    I am attempting to follow the tutorial put forth here:

    Please assist, as I have attempted search engine searches and have come no further...

    This is the latest version 2.5.0
    Last edited by Nyanpasu; 08-01-2018, 10:52 AM. Reason: Added versionne number.