Announcement

Collapse
No announcement yet.

WaveEngine installer won't find Gtk Sharp

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • WaveEngine installer won't find Gtk Sharp

    Gymya people,

    I'm new here so can I be welcomed? :3

    Well, as the title says, the current installer of WaveEngine doesn't find Gtk Sharp in any way, I'll detail:

    I had Gtk# before, so when I saw that I needed it, I thought that I had an old version or something, so I didn't check anything. When all the prerequisistes installed without problems, I noticed that the installer notified that the Gtk# one went wrong, I simply tried again and it didn't work.

    Next I did is, as I usually do, uninstall it and search it manually (three different versions tested; 2.12.42, 2.12.44 and 2.12.26 which is the one that the installer searchs by default), it didn't work, searching online I saw in these forums that something similar happened, I tried the solutions in there (uninstalling Xamarin, reinstalling everything, rebooting, WinXP compatibility, checking the PATH variable to make sure it was right) and tried things on my own;

    I have Windows 7 x86, with the XP compatibility it doesn't pop the prerequisite checker, but when it finishes installing it just appears on the Task Manager as a process, crashes (it pops the diagnostic default tool as well, but it disappears without any window poping) and bye bye.
    I also tried getting the msi and .cab manually (in the Temp directory, while the XP-Compatible-Installer was doing it's work) and executing it, but it requires a bootstrapper so nothing can be done.
    With getting an already installed WaveEngine directory (from another computer/person), happens the same that with XP.

    Any ideas?

  • #2
    Originally posted by GhoulMage View Post
    (three different versions tested; 2.12.42, 2.12.44 and 2.12.26 which is the one that the installer searchs by default), it didn't work
    Hey man!
    what didn't work? the gtk# installer or the waveengine installer, and what was the error message?

    Comment


    • #3
      The Gtk# installed perfectly, it's just that WaveEngine Prerequisite Checker/Installer doesn't detect that I have Gtk#, in any situation. No error message at all.

      Comment


      • #4
        Hi there!

        Here is a link for the gtk sharp installer version that uses de installer try to install it manually and it should do the trick.

        For the installer prerequisites we look for a centain key in the windows register to check if there is a version installed, and I am afraid is not finding for you, hope this solves your problem.

        Please keep us posted if the problem is not solved :-(

        Comment


        • #5
          Yeah, version 2.12.42 is the first one that I tried, becuase it was the one that the installer used for default, but it doesn't work.
          Which registry key does look to check Gtk#? Maybe I can try to edit it?

          Comment


          • #6
            Hi GhoulMage ,

            Have you check the log file from WaveEditor? You can find the log file at:
            [AppData]\Roaming\WaveEditor2\Logs
            .
            The file is called:
            WaveEditor.exe_EventLog.txt
            .
            The exception should be written at the bottom of the file (try to run the app just before open the log).
            It could launch some light over this problem.

            Regards.

            Comment


            • #7
              It is not the Editor, but the Preinstaller.

              Anyway, I checked and there are logs but all empty.

              Comment


              • #8

                Hi @GhoulMage,

                Are you running the installer as adminsitrator?

                The installer search the following registry key:
                - HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Xamarin\Gt kSharp\Version\ with the content "M2.12.42"

                Can you check that this key exists?

                Greetings
                Daniel Cáceres

                Comment


                • #9
                  Ah, yes I'm running it as an administrator.

                  Searching that I've found that it didn't exist there, but just one path upper it exists this Xamarin/GtkSharp with Version and InstallFolder keys. I just copied that into WoW6432Node and the installer detected me the Gtk# correctly, many thanks for that~!.

                  Now the issue I have is that it doesn't execute, someone said to install Xamarin and try again, I'm gonna do that and show here if it worked or not in few moments.

                  Comment


                  • #10
                    I can not install Xamarin due to compatibility issues.

                    Comment


                    • #11
                      Have you treid removing everything and starting with http://www.monodevelop.com/download/ and then going on to intall Wave?

                      That's how I got it to work.

                      Also try getting rid of XP compatibility and just run it native in W7.

                      Comment


                      • #12
                        Hi,

                        Wave Engine editor exactly requires GTK# 2.12.42. You can download it from this link.
                        Try to install it (use Admin previleges) and try again!

                        If this fails, it is probably related to the registry. The installer looks for SOFTWARE\Wow6432Node\Xamarin\GtkSharp\Version\. Can you please check (using regedit.exe) if there is an entry at that path, and whether it is 2.12.42?
                        1zqpq2c.png
                        Regards.

                        Depending on the setup the registry can also be HKEY_LOCAL_MACHINE\SOFTWARE\Xamarin\GtkSharp\Versi on

                        Comment


                        • #13
                          Well, sorry but I'm gonna start complaining.

                          First of all, there's a bunch of replies here where I say repeatedly what I tried to do, and that none of them worked. So please do not suggest the same things as other people have, it's just redundant.

                          Mark suggestion didn't work also.

                          I guess I'm gonna have to buy a new computer to just make it work.

                          Comment


                          • #14
                            Hi GhoulMage,

                            It seems a issues with the installer prerequisite checker on Windows 7. The register key path is different in W8 and W10. Anyway after reading your posts. I understand that you continue having problems with de WaveEditor start app. So we are going to try get more info, please follow these steps:

                            Open Event viewer step by step:

                            1 - Press the keys (Windows key + r)
                            2 - Write "eventvwr" on run prompt

                            Click image for larger version  Name:	RunEventViewer.png Views:	2 Size:	7.4 KB ID:	9365

                            Inside Event viewer you can see the applications logs
                            Windows Logs-> Applicaion



                            After launch WaveEditor on top table you can see the last errors. Maybe here we can find more info about the crash.

                            I'm looking forward to hearing from you about the info!

                            Regards,
                            Jorge Canton

                            Comment

                            Working...
                            X