Announcement

Collapse
No announcement yet.

TiledMap loading error

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • TiledMap loading error

    Hi guys.
    So, I'm trying to load my TiledMap into WaveEngine and I'm having some difficulties.
    Before I had a problem exactly like this guy (https://forum.waveengine.net/forum/g...me-elapsedtime), but unfortunately the files he and Jorge uploaded are too old now to download so I don't know what they fixed.

    Now after struggling and redoing my map after a 100 times, this error disappeared but now I get another. The tilemap.Properties throws a NullReferenceException at WaveEngine.TiledMap.TiledMap.getProperties(). The game runs, but the TiledMap is nowhere. And now I'm hopeless.

    I'm quite sure I checked every example and forum report about this and none of those seem to help me. The Tiled version is the latest 0.17.0 although I've tried to do it with 0.16.0 and 0.14.0 as well and Wave version is 2.3. I've tried it with 2.2 too, but since I've updated it, hoping that this new version will fix the problem.

    I've tried doing my map with separate tile images and tilesets, neither of those was good.

    Can you help me? I have a 60*40 map, but I've created a 10*10 map for debugging purposes, which causes the same error. I will attach it, I don't need anything special, image or object layers, just the tile structure for my game. I guess the problem is with this.

    Great engine though, keep up the good work.
    Thanks in advance.
    Attached Files

  • #2
    Hi Webnosium,

    Into your map3.zip file only has a tmx file, Can you send us the tileset.png that you are using to load your tiledmap?. Remember that if you want to load a Tiledmap file you need two files tmx and tileset image.

    I'm looking forward to hearing from you.
    Jorge Cantón

    Comment


    • #3
      Yes, of course. It's just a 5-tile tileset image.
      Attached Files

      Comment


      • #4
        Hi Webnosium,

        I have attached a sample, derived from the TiledMap sample available here (https://github.com/WaveEngine/Sample...sions/TiledMap) using your tmx file with a key/value in the props dictionary and png.
        Right now, if you provide an empty you will get a null in the props instead of an empty dict.
        Sample is here: https://ufile.io/073

        Hope this helps.

        Comment

        Working...
        X