Announcement

Collapse
No announcement yet.

WaveEditor.exe won't start

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • WaveEditor.exe won't start

    It says that WaveEditor.GTK Windows has stopped working, and in the details it mentions System.TypeInitialization.

    I've installed all WaveEngine prerequisites.

    Attached are all three associated Event Viewer logs.

    Suggestions?
    Attached Files

  • #2
    The same thing is happening to me! What's going on?

    Comment


    • #3
      Seems like we've been abandoned.

      Comment


      • #4
        The same. Some problems with GTK or rather execution of GTK from Wave Editor.

        Comment


        • #5
          I choose debug with Visual Studio and get this message. I create file test.weproj by specified path and paste content from here , editor open with some error but it works

          Comment


          • #6
            Maybe an application cache should be deleted. A new version arrived and this could be a problem. I will try with it today when I come back home after my work.

            Comment


            • #7

              Please, try to delete the file C:\Users\[Youruser]\AppData\Roaming\WaveEditor2\UserData, and if it still crashing, please send us the Logs folder from the same path to see whats going on.

              Hope this helps!

              Comment


              • #8
                Yes, deleting this folder helped me and the editor working fine again. Time to fixing the installer or editor at start up to avoid such problems in the future. I had similar problem previously on Linux.

                Comment


                • #9
                  juanlao : I did as you said, and now I'm not getting exceptions but it still isn't starting. I'm attaching the log from the "C:\Users\USERNAME\AppData\Roaming\WaveEditor2\Log s" folder.
                  Attached Files

                  Comment


                  • #10
                    try to take a look to this post:

                    https://forum.waveengine.net/forum/g...fail-to-launch

                    hope it helps

                    Comment


                    • #11
                      Tried that. It didn't help.

                      Comment


                      • #12
                        ( I can't edit my previous message... )

                        Apparently SharpDX.dll is throwing an exception, but it just causes the program to close immediately.

                        From the log:

                        ERROR - UnhandledException | SharpDX.SharpDXException: HRESULT: [0x887A0001], Module: [SharpDX.DXGI], ApiCode: [DXGI_ERROR_INVALID_CALL/InvalidCall], Message: Unknown
                        at SharpDX.Result.CheckError()
                        at SharpDX.DXGI.Factory.CreateSwapChain(ComObject deviceRef, SwapChainDescription& descRef, SwapChain swapChainOut)
                        at SharpDX.Direct3D11.Device.CreateWithSwapChain(Adap ter adapter, DriverType driverType, DeviceCreationFlags flags, FeatureLevel[] featureLevels, SwapChainDescription swapChainDescription, Device& device, SwapChain& swapChain)
                        at WaveEngine.Adapter.BaseApplication.CreateSwapChain (IntPtr windowsHandler)
                        at WaveEngine.Adapter.BaseApplication.Configure(IntPt r windowsHandler)
                        at WaveEditor.WaveIntegration.DirectXWidget.OnExposeE vent(EventExpose evnt)
                        at Gtk.Widget.exposeevent_cb(IntPtr widget, IntPtr evnt)

                        Comment


                        • #13
                          Hi SnoogyLips,

                          Seems a problem when SharpDX(DirectX) creates the SwapChain on your system.

                          Are you using Windows 7?

                          Which graphics card are you using?

                          Are you using the last 2.1.1 WaveEngine version?


                          I'm look forward to hearing from you.

                          Regards!
                          Jorge Canton

                          Comment


                          • #14
                            Jorgemagic :

                            Windows 7 Ultimate 64bit.

                            AMD Radeon R7 260x.

                            Yes.

                            When I'm using the latest version from the download page (but not running the updater) I get to the login page and when I login it immediately closes and provides that log. However, I also tried running the updater and it got a new version(?) which gives me the System.TypeInitialization exception before letting me login.

                            EDIT : I've tried using the earliest Shark build and it had the same problem after attempting to login.

                            Comment


                            • #15
                              Okay, weird, now it suddenly works...?

                              EDIT : Except that it resized itself so that the top of the window is off the screen. >:S ( http://prntscr.com/b27gnb )
                              Last edited by TheSnoogyLips; 05-10-2016, 12:31 AM.

                              Comment

                              Working...
                              X