Announcement

Collapse
No announcement yet.

waveeditor fail to launch...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • waveeditor fail to launch...

    waveeditor installed on my machine fail to launch because it want to load my previous now non existing folder, here's the capture of my debugging process...i'm using newest version installer i downloaded today. my machine is windows 10, 64 bit, nvidia gpu 720M 2GB, memory 6 GB, proc I3 3217U, 1.7Ghz


  • #2
    Hi sdb7. I had the same problem and this is how I solved it.

    1) Create filepath [E:\Works\WaveEngines\Testing2\test\]

    2) Goto location [C:\Program Files (x86)\WaveEngine\v2.0\Tools\VisualEditor\UpgradeTe mplates\_2_1_0] and copy file [ProjectTemplate.weproj] to the above location

    3) Back in location [E:\Works\WaveEngines\Testing2\test\], rename to test.weproj. It's case sensitive.

    4) Reopen WaveEngine. It should work.

    The problem is that the Start Page -> Recent tries to map old projects and the devs did not factor for DirectoryNotFound exception which will happen if the user deletes a project they no longer need. This is a major bug and I hope someone at WaveEngine patches this.

    Comment


    • #3
      Hi there!

      There is a more "simplier" workarround, and is avoiding wave editor loads last project when opening by default.

      You can find this file in

      $(user_folder)/AppData\Roaming\WaveEditor2\UserData.xml


      and change this value :

      <d4p1:LastOpenedProject>$(route_old_project)</d4p1:LastOpenedProject>
      to

      <d4p1:LastOpenedProject></d4p1:LastOpenedProject>

      And when the editor loads (not crashing miserably this time) you can reset this propperty in
      Edit -> Preferences -> OpenLastProjectAtStarup -> check/uncheck

      And it will be hopefully solve for the next release.

      Thanks and sorry for the inconvenience.

      Comment


      • #4
        Originally posted by mgomar View Post
        Hi there!

        There is a more "simplier" workarround, and is avoiding wave editor loads last project when opening by default.

        You can find this file in

        [/B]

        and change this value :



        to




        And when the editor loads (not crashing miserably this time) you can reset this propperty in
        Edit -> Preferences -> OpenLastProjectAtStarup -> check/uncheck

        And it will be hopefully solve for the next release.

        Thanks and sorry for the inconvenience.

        This fixed my problem, "simplier" and effective, thanks

        Comment

        Working...
        X